This version of connectivity will break your Android build if it or its dependencies aren’t compatible with AndroidX. Hatasının Çözümü

WARNING: This version of connectivity will break your Android build if it or its dependencies aren’t compatible with AndroidX.

 

Android IDE sürümü yükseltiğimizde  ve eski bir projesimizi açmaya çalıştığımızıda bu hata ile karılaşırız.

Çözüm:

gradle.properties dosyamıza

şu kodu yazıyoruz

android.useAndroidX=true
android.enableJetifier=true
bunu yaptıktan sonra aynı hatayı almayadevam ederseniz
Refactor kısmından projenizi AndroidX e çevirebilirsiniz

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir